Archive for 11月, 2012

WordPressを3.4.2にアップデート

金曜日, 11月 30th, 2012


3.0.4-jaから一気にアップデートしてみました。多分トラブルと思ってデータベースとファイルを全てパックアップして慎重に行ったのですが、見た目は問題なくアップデートできたようです。

1. mysqldumpかphpMyAdminでデータベースをバックアップする。

2. 管理画面より全てのプラグインを停止させる。

3. 今回はFTPで3.4.2.の全ファイルを上書きアップロード

4. /wp-admin/ にアクセスしてデータベースを再読み込み

以上ですんなりとアップデートできました。

3.4.2.対応と書いてないプラグインもアップデートしてみましたが特に問題がないようです。

一息付いているともう3.5とか始まってるので、利用者は追いつくのが大変ですね。

それにしてもFirefoxでアクセスしたら「ご使用のプラウザは古すぎます」って、きっとYour Browser is TOO old. とかを翻訳したんだと思うけど、なんかすみませんって感じになりました(笑)。

Plesk 9.2.1でphpを5.2.17にアップデート

水曜日, 11月 28th, 2012


専用サーバーの1つで2013年6月に正式サポートが終了するPlesk9で稼動しているサーバーがありますが、ハードウェアファイアーウォールを接続しているということで当分使用することになりました。セキュリィティ的には安定しているのですが、php5.1.6だったためそろそろワードプレスのプラグインが5.2以上でないと対応しない状態になってきて、今回アップデートしました。

普通にアップデートしますとPlesk9.2.1が作動しなくなりますので、いくつかの作業が必用になります。先入観でものすごく難しいはずだと思っていたのですがネット上に先駆者がいまして、それでも不安なので技術に頼んだら1人は無理だぜ..この際Plesk11にしてデータ移行しようよっ..て勝手なこと言って、さてどうしたものかと困っていたらもう一人の技術がなぜか詳しくて、できるよ..だめだったら5.1.6に戻せばいいからやってみると許可も取らずにさっさとアップデート。

だけどうんぬんと話していたら、終わったけどどう?...@@….

相談してから5分もたってないのに、さっさとアップデート。しかもPlesk9.2.1も動いていて、ワードプレスも特に問題なさそう。

技術もそれぞれ得意分野があるみたいで、最初から無理って決め付けてはいけないと反省しました。でもお客さんのサーバーだとどうしても慎重になってしまうんですよね。

ここに関連トピックスがあります。やりかたは私に質問されても分かりませんので、あしからずです。

ほとんど休眠状態のこのブログですが、会社はちゃんと生きていますのでクラウドサーバーならびに専用サーバーのお問い合わせお待ち申し上げております。

12月にラスペガスに新データセンターをオープンします。地震などのリスク分散のためにも海外サーバーにミラーサイトを持ちましょう。